Symptom

When defining a connection to an MYOB Advanced tenant, the user is presented with a message about one or more inquiries not being set up and asking if the user would like to create them:

setup_inquiries.png

After clicking Yes, the user is presented in an error message:

setup_inquiries_error.png

Text from the Error Message:

An error occured during configuration of inquiry VelixoReportPro-xxxxxxxx.  Please ensure that you ahve the necessary access rights to create a Generic Inquiry.

System.Web.Services.Protocols.SoapException: Server was unable to process request. --->

System.NullReferenceException: Object reference not set to an instance of an object.

Cause

This error is being returned by MYOB Advanced and indicates that the user does not have sufficient permissions to create the Generic Inquiry

Resolution

A MYOB Advanced Admin (or other user with sufficient access rights) will need to use the Velixo Reports add-in to create the Generic Inquiry